Automate is facing issues

Incident Report for BrowserStack

Resolved

This incident has been resolved.
Posted May 03, 2025 - 12:38 UTC

Investigating

We are currently investigating this issue.
Posted May 03, 2025 - 12:37 UTC
This incident affected: Automate.