AppAutomate is facing issues
Incident Report for BrowserStack
Resolved
We're back! Everything should be up and running.
Posted Jul 23, 2024 - 04:56 UTC
Investigating
We are currently investigating this issue.
Posted Jul 23, 2024 - 04:55 UTC
This incident affected: App Automate.