Live is facing issues

Incident Report for BrowserStack

Postmortem

Between 12:11 UTC and 12:20 UTC on 9th September 2025, users of the Live product were unable to load the dashboard and were seeing the message "This website is under heavy load". The issue was caused by a sudden spike in traffic, which led to service disruption. The problem was mitigated and all systems were fully restored by 12:20 UTC.

We sincerely apologize for the inconvenience caused and are taking steps to strengthen our systems to prevent similar issues in the future.

Posted Sep 11, 2025 - 14:15 UTC

Resolved

This incident has been resolved.
Posted Sep 09, 2025 - 12:20 UTC

Investigating

We are currently investigating this issue.
Posted Sep 09, 2025 - 12:11 UTC
This incident affected: Live.