User Reports and Team Reports are currently unavailable

Incident Report for BrowserStack

Resolved

The issue has now been resolved, and User Reports and Team Reports are loading as expected.
Posted Jul 14, 2026 - 14:42 UTC

Investigating

Our team is actively working on resolving this issue, and we expect it to be resolved shortly. We apologize for any inconvenience caused.
Posted Jul 14, 2026 - 12:40 UTC