Intermittent service degradation
Incident Report for BrowserStack
Resolved
This incident has been resolved.
Posted 2 months ago. Aug 12, 2019 - 18:03 UTC
Investigating
We are experiencing issues with one of our Desktop Datacenters due to which you may experience intermittent service degradation. We are actively working on resolving the issue to ensure minimal impact to your test runs.
Posted 2 months ago. Aug 12, 2019 - 11:13 UTC