App Automate is facing issues
Incident Report for BrowserStack
Resolved
We're back! Everything should be up and running.
Posted 11 days ago. Sep 09, 2019 - 17:15 UTC
Investigating
We are currently investigating this issue.
Posted 11 days ago. Sep 09, 2019 - 17:13 UTC