App Automate is facing issues

Incident Report for BrowserStack

Postmortem

We experienced a temporary service disruption affecting Appium session initiation on App Automate.

Impact

  • Approximately 41 minutes of degraded access to App Automate services
  • Customers in specific regions (US-East and EU-West) were unable to reach the selenium hub endpoints
  • Resulted in appium session initialization failures for a subset of users

Cause
A temporary issue in our network routing layer led to failures in resolving App Automate hub requests. The underlying factors are still being investigated.

Resolution
Systems recovered after routing stabilised, restoring normal service.

We sincerely apologize for the inconvenience caused. If you continue to experience any issues, please reach out to our Support team.

Posted Oct 23, 2025 - 12:02 UTC

Resolved

This incident has been resolved.
Posted Oct 22, 2025 - 07:49 UTC

Investigating

We are currently investigating this issue.
Posted Oct 22, 2025 - 07:05 UTC
This incident affected: App Automate.