Test Observability - Dashboard is facing issues

Incident Report for BrowserStack

Resolved

We're back! Everything should be up and running.
Posted Mar 14, 2025 - 17:09 UTC

Investigating

We are currently investigating this issue.
Posted Mar 14, 2025 - 17:08 UTC
This incident affected: Test Observability (Dashboard).