AppAutomate is facing issues

Incident Report for BrowserStack

Resolved

We're back! Everything should be up and running.
Posted Nov 07, 2023 - 05:47 UTC

Investigating

We are currently investigating this issue.
Posted Nov 07, 2023 - 05:46 UTC
This incident affected: App Automate.