Automate is facing issues
Incident Report for BrowserStack
Resolved
This incident has been resolved.
Posted Feb 22, 2024 - 11:10 UTC
Investigating
We are currently investigating this issue.
Posted Feb 22, 2024 - 11:09 UTC
This incident affected: Automate.