Automate is facing issues

Incident Report for BrowserStack

Resolved

We experienced an issue that may have impacted test execution for some users using Local Testing. All services are now operating normally.
This incident has been resolved.
Posted Jun 13, 2025 - 16:26 UTC

Investigating

We are currently investigating this issue.
Posted Jun 13, 2025 - 16:12 UTC
This incident affected: Automate.