Test Insights reports temporarily unavailable

Incident Report for BrowserStack

Resolved

The issue has now been resolved, and Test Insights is loading as expected.
Posted Jul 02, 2026 - 06:00 UTC

Investigating

Test Insights reports were temporarily unavailable due to downtime in a third-party library used to load the reports.
Posted Jul 02, 2026 - 05:30 UTC