Automate is facing issues

Incident Report for BrowserStack

Resolved

Between 15 Aug 2025, 19:32 UTC and 19:48 UTC, we experienced network-related issues affecting the US region. This may have impacted users running sessions in that region.

The issue has since been resolved, and all affected services are now fully operational.

We sincerely apologize for any inconvenience this may have caused and appreciate your patience.
Posted Aug 15, 2025 - 19:48 UTC

Investigating

We are currently investigating this issue.
Posted Aug 15, 2025 - 19:32 UTC
This incident affected: Automate.