Automate is facing issues

Incident Report for BrowserStack

Postmortem

We encountered a service disruption impacting session initiation on Automate.

Impact

  • Around 40 minutes of degraded access to Automate services.
  • Customers in certain regions (US-East and EU-West) were unable to connect to Selenium hub endpoints, resulting in session initialization failures for some users.

Root Cause

A temporary issue within our network routing layer prevented proper resolution of Automate hub requests. We are continuing to investigate the underlying causes.

Resolution

Systems recovered after routing stabilised, restoring normal service.

We sincerely apologize for the inconvenience caused. If you continue to experience any issues, please contact our Support team.

Posted Oct 23, 2025 - 17:54 UTC

Resolved

This incident has been resolved.
Posted Oct 22, 2025 - 07:49 UTC

Investigating

We are currently investigating this issue.
Posted Oct 22, 2025 - 07:06 UTC
This incident affected: Automate.