TestManagement is facing issues

Incident Report for BrowserStack

Resolved

We're back! Everything should be up and running.
Posted Mar 07, 2025 - 13:06 UTC

Investigating

We are currently investigating this issue.
Posted Mar 07, 2025 - 13:01 UTC
This incident affected: Test Management.