App Automate is facing issues
Incident Report for BrowserStack
Resolved
We're back! Everything should be up and running.
Posted about 1 month ago. Aug 16, 2019 - 14:50 UTC
Investigating
We are currently investigating this issue.
Posted about 1 month ago. Aug 16, 2019 - 14:49 UTC