AppLive is facing issues

Incident Report for BrowserStack

Resolved

We're back! Everything should be up and running.
Posted Nov 20, 2023 - 23:27 UTC

Investigating

We are currently investigating this issue.
Posted Nov 20, 2023 - 23:22 UTC
This incident affected: App Live.