Observability API - Dashboard marked DOWN!

Incident Report for BrowserStack

Resolved

This incident has been resolved.
Posted 4 days ago. Apr 02, 2025 - 13:12 UTC

Investigating

We are currently investigating this issue.
Posted 4 days ago. Apr 02, 2025 - 13:11 UTC
This incident affected: Test Observability (Dashboard).