TestManagement is facing issues

Incident Report for BrowserStack

Resolved

We're back! Everything should be up and running.
Posted Feb 08, 2025 - 15:33 UTC

Investigating

We are currently investigating this issue.
Posted Feb 08, 2025 - 15:23 UTC
This incident affected: Test Management.