Automate is facing issues
Incident Report for BrowserStack
Resolved
We're back! Everything should be up and running.
Posted 10 days ago. Sep 10, 2019 - 09:42 UTC
Investigating
We are currently investigating this issue.
Posted 10 days ago. Sep 10, 2019 - 09:41 UTC