Test Observability - Dashboard is facing issues

Incident Report for BrowserStack

Resolved

We're back! Everything should be up and running.
Posted 1 day ago. Mar 14, 2025 - 17:14 UTC

Investigating

We are currently investigating this issue.
Posted 1 day ago. Mar 14, 2025 - 17:13 UTC
This incident affected: Test Observability (Dashboard).