Test Observability - Dashboard is facing issues

Incident Report for BrowserStack

Resolved

We're back! Everything should be up and running.
Posted Mar 04, 2025 - 12:34 UTC

Investigating

We are currently investigating this issue.
Posted Mar 04, 2025 - 12:33 UTC
This incident affected: Test Observability (Dashboard).