App Automate is facing issues

Incident Report for BrowserStack

Resolved

App Automate experienced a temporary service disruption impacting a subset of sessions during the affected time window. The issue has been resolved, and all services were fully restored by 02:48 UTC.
Posted May 14, 2026 - 02:48 UTC

Investigating

We are currently investigating this issue.
Posted May 14, 2026 - 01:40 UTC
This incident affected: App Automate.