Test Insights reports temporarily unavailable

Incident Report for BrowserStack

Resolved

Test Insights reports are now available.
Posted Sep 07, 2026 - 06:40 UTC

Investigating

Test Insights reports will be unavailable from 2026-09-07 06:00 UTC to 2026-09-07 08:00 UTC due to a planned infrastructure upgrade.
Posted Sep 07, 2026 - 06:00 UTC