Automate is facing issues
Incident Report for BrowserStack
Resolved
This incident has been resolved.
Posted Mar 25, 2024 - 11:43 UTC
Investigating
We are currently investigating this issue.
Posted Mar 25, 2024 - 11:33 UTC
This incident affected: Automate.