Live is facing issues
Incident Report for BrowserStack
Resolved
This incident has been resolved.
Posted 6 days ago. Aug 12, 2019 - 10:19 UTC
Update
We are experiencing issues with one of our Desktop Datacenters due to which you may experience intermittent service degradation. We are actively working on resolving the issue to ensure minimal impact to your test runs.
Posted 6 days ago. Aug 12, 2019 - 10:13 UTC
Investigating
We are currently investigating this issue.
Posted 6 days ago. Aug 12, 2019 - 10:11 UTC