AppAutomate is facing issues
Incident Report for BrowserStack
Resolved
We're back! Everything should be up and running.
Posted Sep 11, 2020 - 23:13 UTC
Investigating
We are currently investigating this issue.
Posted Sep 11, 2020 - 23:11 UTC