AppAutomate is facing issues
Incident Report for BrowserStack
Resolved
We're back! Everything should be up and running.
Posted Sep 22, 2020 - 14:54 UTC
Investigating
We are currently investigating this issue.
Posted Sep 22, 2020 - 14:47 UTC